Skip to main content

AccessTr.neT


Çalışıyor - İzinli Kontrolü

Çalışıyor - İzinli Kontrolü

Çözüldü #1
Merhaba

Kullanmakta olduğum puantajda personeller Çalışıyor ise "X" İzinli ise "İZ" yazıyorum. Açıklama satırında bugün() tarihini baz alıp iz yazıyorsa "İZİNLİ" X yazıyorsa "ÇALIŞIYOR" yazması için nasıl bir formül uygulamam lazım yardımcı olabilirmisiniz.
.rar PUANTAJ.rar (Dosya Boyutu: 7,04 KB | İndirme Sayısı: 16)
Cevapla
#2
Alttaki formülü AF1 hücresine ekleyip alta çekiniz.
Kod
=EĞERHATA(EĞER(DOLAYLI(ADRES(SATIR();KAÇINCI(BUGÜN();$1:$1;0);3))="X";"Calisiyor";"izinli");"Bugüne esit tarih yok")
Cevapla
#3
Teşekkür Ederim. Sağolasın.
Cevapla
#4
Rica ederim,kolay gelsin.
Cevapla
#5
Birde içiçe eğer ile yaptım ve alta çekince boş varsa boş çıksın ekledim.
iki formülüdedeneyebilirsiniz uzun olan iç içe eğer ile ve iz ve X e göre şart arıyor diğeri ise sadece x varsa çalışıyor x yoksa izinli yazıyor.
ilk formüle x ve iz harici varsa onlarda eklenebilir eğer olarak.

Kod
=EĞER($A2="";"";EĞERHATA(EĞER(DOLAYLI(ADRES(SATIR();KAÇINCI(BUGÜN();$1:$1;0);3))="X";"Calisiyor";EĞER(DOLAYLI(ADRES(SATIR();KAÇINCI(BUGÜN();$1:$1;0);3))="İZ";"izinli";""));"Bugüne esit tarih yok"))
Kod
=EĞER($A2="";"";EĞERHATA(EĞER(DOLAYLI(ADRES(SATIR();KAÇINCI(BUGÜN();$1:$1;0);3))="X";"Calisiyor";"izinli");"Bugüne esit tarih yok"))
Cevapla

Bir hesap oluşturun veya yorum yapmak için giriş yapın

Yorum yapmak için üye olmanız gerekiyor

ya da