Skip to main content

AccessTr.neT


Çoketopla Fonksiyonunda Tarih Toplamlarını Ay Bazında Ölçütlendirme.

Oğuz Türkyılmaz
Oğuz Türkyılmaz
1
313

Çoketopla Fonksiyonunda Tarih Toplamlarını Ay Bazında Ölçütlendirme.

Çözüldü #1
Merhabalar
Üzerinde bütün gün uğraştığım fakat kaynaklarda bu tarz bir çözüme rastlamadığım için formülüm yarıda kaldı.
[Resim: do.php?img=10714]
Uyguladığım formüle Masraf Tarihi Sütunundaki masraf tarihlerini Ölçüt aralığı olarak gösterip yapılan masraflara Ay bazında ölçüt vermeyi beceremedim. Uyguladığım formülle 3.Ölçüt aralığı olarak  B sütununu Ölçüt olarak I2 hücresindeki Ocak değerini eklemek böylece bu formülle ocak ayı bazında 01 nolu firmanın masraf türlerine göre harcama toplam tutarlarını hücrede göstermek istiyorum.
Yani şu an resimde gözüken C3 hücresindeki 420,50 tl lik değerin Ocak ayındaki toplamı vermesini sağlamak istiyorum. Bu formüle 3.ölçütü nasıl verebilirim. Teşekkürler.
[Resim: do.php?img=10712]
[Resim: do.php?img=10713]
.rar MASTER .rar (Dosya Boyutu: 4,09 MB | İndirme Sayısı: 4)
Access Çekirgesi 
[Resim: img-cray.gif]


Son Düzenleme: 12/02/2021, 01:09, Düzenleyen: Oğuz Türkyılmaz.
Cevapla
#2
Sonunda çözdüm problemimi. Çözüm yolunu buraya bırakıyorum belki birisinin derdine çare olur.

Kod
=ÇOKETOPLA('Ana Sayfa'!$G:$G;'Ana Sayfa'!$H:$H;TANIMLAR!$C$1;'Ana Sayfa'!$C:$C;TANIMLAR!$B$1;'Ana Sayfa'!$E:$E;TANIMLAR!$A1)

Masraf tarihlerinin gün ay yıl bilgisinden AY bilgisini
=AY(B4)
formülü ile bir sütunda gösterip ölçüt aralığına bu sütunu verdikten sonra ölçüt olarak da istenen ay bilgisini verebiliyorsunuz.

[Resim: do.php?img=10715]
[Resim: do.php?img=10716]

Teşekkürler. Konuyu taşıyabilirsiniz.
Access Çekirgesi 
[Resim: img-cray.gif]


Cevapla

Bir hesap oluşturun veya yorum yapmak için giriş yapın

Yorum yapmak için üye olmanız gerekiyor

ya da