Skip to main content

AccessTr.neT


Formülleri Sabitleme

emir ustaoğlu
emir ustaoğlu
4
1925

Formülleri Sabitleme

#1
Merhabalar;

Çalışmış olduğum firmada aylık olarak kdv leri ve işlemiş olduğumuz evrakları muhasebe programımızla karşılaştıra bilmek için hazırlamış olduğumuz bir Excel dosyamız var.

Excel dosyasındaki "KDV BEYANNAMESİ" sayfasında ilgili aya ait tüm hesaplanan kdv iade kdv ve matrahlarını kdv oranlarına göre" %1, %8, %18" ayrı ayrı göre biliyorum. Buraya kadar herşey güzel çalışmakta

ancak bazen çalışma sayfalarına satır eklememiz gereke biliyor geç gelen evrak olduğunda bu gibi durumlarda  eğer satırı formülün başladığı yere yaparsak,
Örneğin ekli dosyadaki "Yurtiçi Satışlar" sayfasında veri girme alanı A7 ile J16 aralığındaki tablo da burada bulunan E20 hücresinde ETOPLA formülü ile I:I16 sutundaki %1 kdv li olan satışların kdv oranlarını toplamakta
Kullanmış olduğum ETOPLA formulü; ( =ETOPLA(H7:H16;1;G7:G16) ) eğer burada A7 satırına yeni alan eklemek istersek formülümüz otomatik olarak kayıyor ( =ETOPLA(H8:H17;1;G8:G17) )  8. satırdan başlıyor işlem yapmaya ve bu gibi durumlarda da formül kaymasından dolayı eksik toplama işlemi oluyor ve buda KDV BEYANNAMESİ sayfasında fark çıkmasına neden oluyor.
Bura da sormak istediğim bu formülü sabit olarak ETOPLA(H7:H16;1;G7:G16 bu şekilde yapabilir miyiz ? yani tablonun başına ekleme yapıldığında formülde kayma olmasın.
Excel deki bilgim malesef çok detaylı olmadığı için işin için çıkamadım.
Yardımcı olanlara şimdiden teşekkürler.

.rar Kdv Liste Şablonu emir ustaoglu.rar (Dosya Boyutu: 58,24 KB | İndirme Sayısı: 6)
Dünyada Yetirince Anlaşılır Dile Konuşan İnsanlar Var Birazcık da Anlaması İçin Düşünmesi Gerekiyor İnsanların
Cevapla
#2
sayın ustaoglu,

öncelikle,
kendi adıma uygulamanızı inceleme imkanım ve zamanım olmadı fakat ilk etapta bir cevap yazabilmek veya fikir sağlamak adına;

sütun ya da satır sabitlemek için formül üzerinde yer alan satır veya sütun ifadelerinini başına $ (DOLAR) işareti ekleyebilir ve böylece,bu hücresel değeri sabitleyebilirsiniz.ister sadece sütun isterseniz de sadece satır veyahut da her ikisi için de uygulanabilir.tercihe göre kullanım söz konusudur.

ÖRNEK
$A1 ifadesi ile A sütunu sabit olmak üzere satırlar artış gösterebilir.
A$1 ifadesi ile sütunlar artış göstermek üzere satır sabit.
$A$1 ifadesi ile A1 sütunu sabit.

bilginize...iyi çalışmalar,saygılar.
Herkes,kendisinin AR-GE'cisidir...


Konulara eklenen Uygulama içeriğine yönelik Tavsiyeler
Alt Form Denetim Değerlerine ulaşma ve Alt Form Güncelleme
Kapatırken Düzenle (Compact On Close) Seçeneğinin İşaretlenmesi Hakkında
Cevapla
#3
Sayın atoz112 hocam;

Öncelikle değerli cevabınız için teşekkür ederim.

Alıntı:ÖRNEK
$A1 ifadesi ile A sütunu sabit olmak üzere satırlar artış gösterebilir.
A$1 ifadesi ile sütunlar artış göstermek üzere satır sabit.
$A$1 ifadesi ile A1 sütunu sabit.

Yukarıda belirtmiş olduğunuz şekli ile formülleri tekrardan düzenledim ancak yine yapmak istediğim olmadı.

Denemiş olduğum formüller şekilleri;
=ETOPLA($H9:$H20;1;$G9:$G20)
=ETOPLA(H$9:H$20;1;G$9:G$20)
=ETOPLA($H$9:$H$20;1;$G$9:$G$20)
ancak malesef hiç biriyle istediğim sonucu elde edemedim.
9 nolu satırdayken satır ekle dediğimde yine formül kayması meydana gelmekte Img-cray
Dünyada Yetirince Anlaşılır Dile Konuşan İnsanlar Var Birazcık da Anlaması İçin Düşünmesi Gerekiyor İnsanların
Cevapla
#4
sayın ustaoglu,

eğer amacınız,
formüllerin yazılı olduğu D22:H24 hücre alanı içerisinde herhangi bir satır veya sütun eklemeleri nedeni ile genişleme veya hücre dahil olma durumlarının olmaması ise;

bir diğer alternatif çözüm olması veya fikir vermesi adına,eğer ki bu sabitleme işlemi için kullanılan $ (Dolar) işaretinin yeterli olmayacağını düşünüyorsanız,o zaman,

bu formül hücre alanını olduğu gibi yeni bir sayfaya aktarıp o sayfada sadece bu formüllerin olmasını gösterebilirsiniz.

ÖRNEK

=ETOPLA('Yurtiçi Satışlar'!I8:I18;1;'Yurtiçi Satışlar'!G8:G18)
=ETOPLA('Yurtiçi Satışlar'!I8:I18;8;'Yurtiçi Satışlar'!G8:G18)
=ETOPLA('Yurtiçi Satışlar'!I8:I18;18;'Yurtiçi Satışlar'!G8:G18)

EK'te;
bahsi geçen yönteme dair hazırlanmış örnek uygulama mevcuttur.inceleyebilirsiniz.

bilginize...iyi çalışmalar,saygılar.
.rar Kdv Liste Şablonu-ATOZ.rar (Dosya Boyutu: 59,25 KB | İndirme Sayısı: 5)
Herkes,kendisinin AR-GE'cisidir...


Konulara eklenen Uygulama içeriğine yönelik Tavsiyeler
Alt Form Denetim Değerlerine ulaşma ve Alt Form Güncelleme
Kapatırken Düzenle (Compact On Close) Seçeneğinin İşaretlenmesi Hakkında
Cevapla
#5
Sayın atoz112 hocam;

Öncelikle değerli yorumlarınız için teşekkür ederim.

Belirtmiş olduğunuz yöntemleri denedim ve maalesef formülleri sabitleme işlemini gerçekleştiremedim.

Muhasebe de evraklarında düzensiz geldiğini göz önünde bulundurunca satır ekleme işlemininde önüne geçemiyoruz.
Gün içerisindeki konuşmamız esnasında tavsiye etmiş olduğunuz gibi belirli bir sıra gözetmeksizin evrakları işlemek ve ay sonunda tarih sütununa göre eskiden-yeniye sıralama yaparak tarih sırasına almak daha mantıklı ve hızlı bir çözüm.
Katılımlarınızdan ve yardımlarınız dan dolayı teşekkür ederim.

Saygılar iyi çalışmalar..
Dünyada Yetirince Anlaşılır Dile Konuşan İnsanlar Var Birazcık da Anlaması İçin Düşünmesi Gerekiyor İnsanların
Cevapla

Bir hesap oluşturun veya yorum yapmak için giriş yapın

Yorum yapmak için üye olmanız gerekiyor

ya da