Skip to main content

AccessTr.neT M.



Ole Sunucusu / Activex Sorunu

Ole Sunucusu / Activex Sorunu

Çözüldü #1
Merhabalar
Oluşturduğum formda kullandığım butonlar için makro yerine kod kullandığımda böyle bir sorunla karşılaşıyorum. Nasıl bir yol izlemeliyim?
[Resim: Ads-z.jpg]

Cevapla
#2
formunuza eklediğiniz denetimler (metin kutusu, buton, vb) bunları kontrol ediniz. GEREKİRSE İSİMLERİNİ DEĞİŞTİRİNİZ.  en son yaptığınız değişiklikler varsa onlardan başlayınız.
eğer kod ile ilgili olduğunu düşünüyorsanız  önce kodu kaldırıp bi deneyim.  makro yerine kod kullanmakla bi alakasının olacağını sanmam.
kolay gelsin,

husem, proud to be a member of AccessTr.neT since 08-03-2009.
Cevapla
...........
#3
Tekrar tekrar deniyorum fakat örneğin kaydı kaydet makrosu çalışırken, aynı görevi icra edecek butonun tıklandığında olayına DoCmd.RunCommand acCmdSaveRecord yazdığımda, ilk mesajda bulunan ekteki hatayı alıyorum. alan isimlerini kontrol ettim fakat bir sorun bulamadım.

Cevapla
#4
(27/11/2019 11:31)sipuasfaf Adlı Kullanıcıdan Alıntı: Tekrar tekrar deniyorum fakat örneğin kaydı kaydet makrosu çalışırken, aynı görevi icra edecek butonun tıklandığında olayına DoCmd.RunCommand acCmdSaveRecord yazdığımda, ilk mesajda bulunan ekteki hatayı alıyorum. alan isimlerini kontrol ettim fakat bir sorun bulamadım.
Aynı tablo ve formu yeni bir Access dosyası oluşturup içine attığımda hata vermeden çalışıyor.

Cevapla
...........
#5
(27/11/2019 11:33)sipuasfaf Adlı Kullanıcıdan Alıntı:
(27/11/2019 11:31)sipuasfaf Adlı Kullanıcıdan Alıntı: Tekrar tekrar deniyorum fakat örneğin kaydı kaydet makrosu çalışırken, aynı görevi icra edecek butonun tıklandığında olayına DoCmd.RunCommand acCmdSaveRecord yazdığımda, ilk mesajda bulunan ekteki hatayı alıyorum. alan isimlerini kontrol ettim fakat bir sorun bulamadım.
Aynı tablo ve formu yeni bir Access dosyası oluşturup içine attığımda hata vermeden çalışıyor.
Eklediğim alanlardan birer birer kaldırarak hatayı düzeltene kadar devam ettim. yalnızca iki tip alan için bu hatayı alıyorum. Bunlardan birisi tarih diğeri ise açıklama girdiğim alanlar. herhangi bir şart veya giriş maskesi oluşturmadım. Alanların isimlerinde Türkçe karakter bile yer almıyor. Neden böyle bir sorunla karşılaşıyorum acaba?

Cevapla
#6
farklı office versiyonlarıyla çalışıyorsan bundan kaynaklı.
2003 formatındaki uygulamana 2010 da eklemeler yapıyorsun, sonra projeni birleştirdiğinde böyle sıkıntılar oluşabiliyor.
yada 2010 da çalımalarını hazırlayıp 2003 formatındaki dosyanın içine entegre ediyorsun, hatalar vermeye başlıyor.
iyi çalışmalar

Access uygulamasinda tasarladigimiz nesne ve ozellikleri Msys.... sistem dosyalarina kaydedilmekte ve versiyon farkliliklari sistem tablolarinda farklilasmakta. Kopyala yapistir eylemi nesneler uzerinde ki farkli karakter ve bosluklu tanimlamalar, sistem tablolarina uyusmaz referans tanimlamalari olusturuyor. (alıntıdır)

husem, proud to be a member of AccessTr.neT since 08-03-2009.
Cevapla
...........

Bir hesap oluşturun veya yorum yapmak için giriş yapın

Yorum yapmak için üye olmanız gerekiyor

ya da